Self Signed HTTPS Certificate in Use
Problem Description
Cause
The SSL certificate (used for access to the Web Interface via HTTPS and for use of the REST API via HTTPS) has not been signed by a trusted Certificate Authority. LANTIME devices are shipped from the factory with a self-signed SSL certificate. A self-signed SSL certificate has NO impact on time synchronization services. Depending on your browser's security settings, you may be prevented from accessing the Web Interface via HTTPS, or you may receive a warning to this effect and be prompted to add an exception. Calls to the REST API via HTTPS may require the use of explicit parameters to use an insecure certificate.
Fix
Log in the Web Interface, open the Security
page –> Certificates
–> Certificates
tab and use the Upload SSL Certificate
button to upload a certificate that has been signed by a trusted Certificate Authority.
The certificate must be uploaded in PEM file format and must contain the certificate and the private key:
-----BEGIN RSA PRIVATE KEY----- private key here -----END RSA PRIVATE KEY----- -----BEGIN CERTIFICATE----- certificate here -----END CERTIFICATE-----
Further Assistance
If further assistance is required, contact Meinberg Technical Support: https://www.meinbergglobal.com/english/support/tech-support.htm
— Manuel Schäfer manuel.schaefer@meinberg.de, last updated 2022-10-05